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Introduction
Welcome to the Agilent VEE family! Agilent Visual Engineering 
Environment (VEE) is a powerful visual language environment that 
dramatically reduces your development time. To get you started 
quickly on Agilent VEE, we have prepared this guide to show you how 
to install and use your new software. This guide also contains two 
tutorials that show you how to communicate with an instrument via 
the USB interface, and how to generate and display a waveform from 
a virtual source.

Installing Agilent IO Libraries
The Agilent IO Libraries Suite software is included when you 
purchase Agilent VEE Pro or Agilent VEE Express. This software 
enables you to communicate with instruments via serial, USB, GPIB 
or LAN interfaces. Follow these simple installation steps:

1 Insert Agilent IO Library Suites CD into the CD- ROM drive. Click 
Install Software in the Agilent IO Libraries Suite 14.2 window to 
begin installation.
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2 The InstallShield® Wizard will guide you through the installation 
process. Click Next to accept the default settings and complete the 
installation.

3 The Agilent Connection Expert Welcome Screen window will 
appear. This application configures the instruments that are 
connected to your PC. You may close this window before 
proceeding to the next step.
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Installing Agilent VEE Pro or Agilent VEE Express
1 Insert the Agilent VEE installation CD and select Install Agilent VEE 

Pro Development, or Install Agilent VEE Express. The InstallShield® 
Wizard will guide you through the installation process. 

In regard to the differences of these products, refer to Page 16.

2 The InstallShield® Wizard will check if Microsoft .NET Framework 
2.0 is installed. If it is not, the following message box will appear. 

After the installation of Microsoft .NET Framework 2.0, the 
InstallShield® Wizard will guide you through the installation for your 
Agilent VEE selection in Step 1.
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3 Accept the license agreement, then click Next.

4 Type your name, company name and product key when the 
Customer Information dialog box appears. The product key is 
contained in the Agilent VEE Pro or Agilent VEE Express Product 
Key Certificate. Click Next to accept the default settings. Select 
Typical Setup when prompted to complete the installation.
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Launching Agilent VEE Pro or Agilent VEE Express
Go to All Programs > Agilent VEE Pro 8.0> VEE Pro 8.0 or All Programs > Agilent 
VEE Express 8.0> VEE Express 8.0 to launch Agilent VEE Pro or Agilent 
VEE Express.

You can access the tutorials, MATLAB demos (only availabe in Agilent 
VEE Pro) as well as sample programs via the Agilent VEE Pro or 
Agilent VEE Express welcome window. You can close the window 
after exploring it.

You can also open sample programs from the menu bar. To open a 
sample program, go to File > Open Example.

Welcome 
Screen

Program 
Explorer

Properties
Window

Tool Bar

Status Bar

Menu Bar

Workspace
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Instrument Communication Tutorial
In this tutorial, we will connect to an instrument via the USB 
interface. Ensure that the Agilent IO Libraries Suite 14.2 is installed before 
proceeding. 

If you do not have a USB instrument, the tutorial for a GPIB 
instrument is similar from Step 3 onwards. 

The following screenshots are sourced from Agilent VEE Pro. Agilent 
VEE Express has similar screenshots.

1 Connect to the instrument via any USB port on your PC. Then, 
turn on the instrument, a Found New Hardware Wizard dialog box 
may appear. Just step through the vizard clicking Next.

2 When the Assign USB device alias dialog box appears, you must 
click OK to register the interface to your system.
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 7
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3 Launch Agilent VEE Pro or Agilent VEE Express, if you have not. 
Click the Instrument Manager button on the tool bar. 

4 The Instrument Manager screen will appear. Click the Find Instrument 
button to automatically detect and configure all instruments 
connected to your PC. Click Yes if the Identify Instrument pop- up 
dialog box appears. This automatically identifies the instrument on 
the USB interface. In this example, an Agilent 34410A digit 
Multimeter is present.

5 Select newInstrument in the Instrument List panel. Then, click 
Direct I/O on the Create I/O Object panel to place a Direct I/O 
object for the selected new instrument on the workspace. This 
object allows you to send/receive commands to/from your 
instrument.

6 Double- click the Direct I/O object's blue transaction bar to add a 
transaction to the Direct I/O object.
8 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide
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7 Type "*IDN?" (include the quotation marks) in the I/O Transaction 
dialog box as shown below. Click OK to proceed.

*IDN? is one of standard commands for programmable instruments 
(SCPI) command that queries the instrument for its identification 
string.

8 After sending the "*IDN?" query to the instrument, you need to 
read back its response. Double- click the text box of the 
newInstrument object to add a new transaction. This time, select 
the transaction to READ a STRING FORMAT text to an output terminal 
named x. The output terminal x will be automatically created when 
you click OK.
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 9
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9 Select Display > AlphaNumeric and place an AlphaNumeric object on 
the workspace to the right of the Direct I/O object.

10 You will now connect the Direct I/O object to the AlphaNumeric 
object. Place the mouse cursor beside the Direct I/O output 
terminal and a square icon will appear. Left- click and drag a line 
to the input terminal of the AlphaNumeric object. Left- click again 
to complete the connection.

11 Run the program by clicking the Run button on the tool bar.

12 The AlphaNumeric object will display the identification string 
output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as 
Tutorial 1.vee.
10 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide



VEE8_QSG.book  Page 11  Monday, March 12, 2007  3:40 PM
Virtual Source Tutorial
In this tutorial, you will generate and display a waveform from a 
virtual source. No instrument is needed.

1 If you have an existing program in your Agilent VEE Pro or Agilent 
VEE Express workspace, select File > New. Then, select Device > 
Virtual Source > Function Generator and place a function generator 
object on the workspace.

2 By default, the function generator will generate a virtual cosine 
waveform at a frequency of 200 Hz, and an amplitude of 1. 
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 11
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3 Select Display > XY Trace and place an XY Trace object to the right of 
the function generator. 

4 Connect the function generator output terminal to the input 
terminal of the XY trace. Place the mouse cursor beside the 
function generator output terminal and a square icon will appear. 
Left- click and drag a line to the input terminal of the XY Trace 
object. Left- click again to complete the connection.

5 Click the Run button on the tool bar and you can see the 
cosine waveform displayed on the XY Trace object. 
12 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide
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6 Select Display > Spectrum (Freq) > Magnitude Spectrum and place a 
Magnitude Spectrum object on the workspace below the XY Trace 
object.

7 Connect a second line from the output of the function generator to 
the input of the Magnitude Spectrum object using the same 
left- click and drag method as described in Step 4.

8 Click the Run button and observe the magnitude spectrum 
display. As the waveform is a 200 Hz cosine, the magnitude 
spectrum displayed will be a vertical line at the frequency of 200 
Hz.
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 13
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9 Change the waveform function on the virtual function generator to 
a square waveform. 
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10 Click the Run button and observe the difference. Agilent VEE 
gives you the flexibility to analyze your signal source in multiple 
graph displays simultaneously. 

11 To save your VEE code, select File > Save As and name the file as 
Tutorial 2.vee
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 15
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Differences Between Agilent VEE Pro and Agilent VEE 
Express

The following table shows the differences between Agilent VEE Pro 
and Agilent VEE Express.

Features Agilent VEE Pro Agilent VEE 
Express

Interfaces GPIB, LAN, 
RS- 232, VXI, PXI, 

SCXI

USB
(Agilent USB 

devices in 
LiveMode Only )

MatlabScript objects & MatlabScript 
engine

Creating RunTime version of Agilent 
VEE programs and secured version of 
Agilent VEE objects

Programmatic changing of instrument 
address

The Callable Server feature, i.e. calling 
Agilent VEE as an ActiveX Automation 
server

The Remote Function feature, i.e. 
importing a UserFunction that runs in 
another Agilent VEE process on a 
remote host computer

Other features
16 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide
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Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 New Features

New Execution Mode and New Data Types -- Beginning with version 8.0, Agilent 
VEE supports two new data types -  Int64 and Boolean and a new 
Execution Mode -  VEE 8.

Watch Window -- This powerful debugging 
feature allows the user to view and edit 
values of variables and lines/terminals 
when debugging. Programs can continue 
execution incorporating any changed 
values.

Minimap -- Never lose track of your objects 
in your workspace again! This feature allows the user to easily navigate in 
a large detail view. It also allows the user to print a re- sized image of the 
detail view. Minimap has a powerful context menu. The user can copy, 
print, save, and email the Minimap using the context menu.

Code Completion and Code Insight-- This 
powerful new feature greatly benefits any 
user who writes formula by reducing 
keyboard inputs, the need for memorization 
and external documentation. You can stay 
in your context, find the information you 
need, insert language elements directly into 
your formula, and even have Agilent VEE 
complete your typing for you.

Programmatic Properties -- This powerful new feature allows the user to 
programmatically (at run time) change color, title, size, location, and many 
other properties of Agilent VEE Objects, .NET objects, and COM objects. 
Build better Agilent VEE GUI easier, quicker!
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide 17
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NIDAQ Support Updated to Include NIDAQmx Drivers -- From Agilent VEE Pro 8.0, 
Instruments Manager can find instruments with NIDAQmx drivers 
automatically.

VISA Style Devices -- Phase out older inconsistent I/O devices (mixed SICL & 
VISA) for a more uniformed approach (VISA) to declare or use I/O 
devices. Backward compatibility is maintained, even though users are 
"encouraged" to use new- style devices.

Record Usability Enhancements -- This new feature provides faster and easier 
methods to declare, build, and unbuild Record Variables or Constants. The 
new built- in function, buildRecord(), allows you to build a record by 
specifying the field names and field values at runtime.

Display Multiple Traces on Graph Objects through a single input pin -- This feature 
allows the user to display multiple traces (an array of traces) with the 
Agilent VEE Graph objects without knowing how many traces there will 
be ahead of time.

Allow Scrolling in Panel View -- Scrollbars can be set to automatically appear 
when your panel view is not large enough to display all objects. This 
feature can be turned on or off by changing the Panel property named 
"ScrollbarsEnabled." The default is off. 

Multiple Transaction Enhancements -- This feature enhances all Agilent VEE 
transaction- based objects (e.g. Direct IO). The user can now perform many 
operations (copy, delete, select, etc.) on multiple transactions and move 
transactions up or down the list easily with the standard keyboard 
shortcuts.

Home -- Agilent VEE 8.0 adds a new Toolbar button , which moves the 
upper- left corner of a program to the upper- left corner of the work 
area(Main, UserFunctions, or UserObjects).

New Instrument Samples -- Updated many instrument samples and added 
many new ones in examples\instrumentIO\InstrumentManagerIntergrated. 
.

18 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 Quick Start Guide
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Agilent Connectivity Products

Agilent provides a complete range of high performance and highly 
reliable products to connect from your PC to your instruments. These 
include networked USB hub, LAN/GPIB gateway, PCI GPIB, USB/GPIB 
and USB/RS232 interfaces. For more information on Agilent 
connectivity products, visit www.agilent.com/find/io.

Agilent Support, Services and Assistance
With Agilent VEE Pro & Agilent VEE Express, you have access to 
Agilent’s worldwide resources for start- up assistance, training classes, 
and update services. As part of the purchase of any Agilent VEE 
product you are entitled to receive technical support free of charge. 
There is no need to register. 

Additional consulting services are available from Agilent. There are 
currently over 30 companies available in North America, Europe, 
Middle East and Asia to help you develop your Agilent VEE solution.

Sign up for the Agilent VEE electronic users group at 
http://www.agilent.com/find/vrf, and get help on using Agilent VEE 
from experts around the world.

E5810A E5805A 10833X 82350B 82357B
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Appendix
Agilent VEE Pro 8.0 Help is now available in other languages. Please 
rename vee.chm in your installation directory to veeEnglish.chm, then 
rename your preferred localized version to vee.chm. For example, 
rename veeJapanese.chm to vee.chm.
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Einführung
Willkommen im Kreis der Agilent VEE- Nutzer! Agilent Visual 
Engineering Environment (VEE) ist eine leistungsfähige visuelle Pro-
grammierumgebung, mit der Sie Ihre Programme erheblich schneller 
entwickeln können. Damit Sie möglichst schnell mit Agilent VEE star-
ten können, wird in dieser Anleitung gezeigt, wie die neue Software 
installiert und verwendet wird. Außerdem beinhaltet diese Anleitung 
zwei Übungseinheiten, in denen erläutert wird, wie über die USB-
Schnittstelle auf ein Instrument zugegriffen und wie eine Wellenform 
von einer virtuellen Quelle generiert und angezeigt werden kann.

Installieren von Agilent IO Libraries
Die Agilent IO Libraries Suite erhalten Sie beim Kauf von Agilent VEE 
Pro oder Agilent VEE Express. Mit dieser Software können Sie über 
serielle, USB- , GPIB-  oder LAN- Schnittstellen auf Instrumente 
zugreifen. Führen Sie folgende einfache Installationsschritte aus:

1 Legen Sie die Agilent IO Library Suites- CD in das CD- ROM- Lauf-
werk ein. Klicken Sie im Fenster von Agilent IO Libraries 
Suite 14.2 auf Install Software, damit die Installation gestartet wird.
2 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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2 Der InstallShield® Wizard führt Sie durch die Installationsvorgänge. 
Klicken Sie auf Next, um die Standardeinstellungen zu übernehmen 
und die Installation abzuschließen.

3 Das Fenster Agilent Connection Expert Welcome Screen wird ange-
zeigt. Mit dieser Anwendung werden die Instrumente konfiguriert, 
die an den PC angeschlossen sind. Sie können dieses Fenster 
schließen, bevor Sie den nächsten Schritt ausführen.
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 3
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Installieren von Agilent VEE Pro oder Agilent VEE Express
1 Legen Sie die Agilent VEE- Installations- CD ein, und wählen Sie 

Install Agilent VEE Pro Development oder Install Agilent VEE Express aus. 
Der InstallShield® Wizard führt Sie durch die Installationsvorgänge. 

2 Der InstallShield® Wizard prüft nun, ob Microsoft .NET 
Framework 2.0 installiert ist. Ist dies nicht der Fall, wird das 
folgende Meldungsfenster angezeigt. 

Nach der Installation von Microsoft .NET Framework 2.0 führt der 
InstallShield® Wizard Sie durch die Installation des Agilent 
VEE- Produkts, das Sie in Schritt 1 ausgewählt haben.
4 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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3 Akzeptieren Sie die Bestimmungen der Lizenzvereinbarung, und 
klicken Sie dann auf Next.

4 Geben Sie Ihren Benutzernamen (User Name), den Firmennamen 
(Company Name) und den Produktschlüssel (Product Key) ein, 
wenn das Dialogfenster "Customer Information" angezeigt wird. Den 
Produktschlüssel finden Sie im Agilent VEE Pro oder Agilent VEE 
Express Product Key Certificate. Klicken Sie auf Next, um die 
Standardeinstellungen zu akzeptieren. Wählen Sie Typical Setup aus, 
wenn Sie aufgefordert werden, die Installation abzuschließen.
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 5
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Starten von Agilent VEE Pro oder Agilent VEE Express
Klicken Sie auf Alle Programme > Agilent VEE Pro 8.0> VEE Pro 8.0 oder auf 
Alle Programme > Agilent VEE Express 8.0> VEE Express 8.0, um Agilent VEE 
Pro oder Agilent VEE Express zu starten.

Über die Begrüßungsseite von Agilent VEE Pro oder Agilent VEE 
Express können Sie auf die Übungsanleitungen (Tutorials), die 
MATLAB- Demos sowie Beispielprogramme (Example Programs) 
zugreifen. Nachdem Sie sich die Begrüßungsseite angesehen haben, 
können Sie diese schließen.

Beispielprogramme können Sie auch über die Menüleiste öffnen. Wenn 
Sie ein Beispielprogramm öffnen möchten, wählen Sie File > Open 
Example aus.

Begrü-
ßungs-
seite

Program 
Explorer

Bereich 
für Eigen-
schaften 
(Properties)

Symbol-
leiste

Status-
leiste

Menü-
leiste

Arbeits-
bereich
6 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung



VEE8_QSG.book  Page 7  Monday, March 12, 2007  3:40 PM
Zugreifen auf ein Instrument - Übungseinheit
In dieser Übungseinheit wird über die USB- Schnittstelle eine Ver-
bindung zu einem Instrument hergestellt. Führen Sie die weiteren 
Schritte erst aus, nachdem Sie sich vergewissert haben, dass die 
Agilent IO Libraries Suite 14.2 installiert ist. 

Wenn Sie kein USB- Instrument haben, können Sie zum Schritt 3 
springen. Die Übungseinheit ist ab diesem Schritt für ein 
GPIB- Instrument gleich. 

Die folgenden Screenshots sind bei einer Installation von Agilent VEE 
Pro erstellt worden. Screenshots für Agilent VEE Express sehen 
ähnlich aus.

1 Stellen Sie über einen USB- Anschluss des PCs eine Verbindung 
zum Instrument her. Das Dialogfenster mit dem Assistenten für das 
Suchen neuer Hardware wird angezeigt. Wählen Sie Nein, diesmal 
nicht aus, damit keine Verbindung zu Windows Update hergestellt 
wird, um nach Software zu suchen. Klicken Sie zum Fortsetzen der 
Installation auf Weiter.

2 Wenn das Dialogfenster "Assign USB device alias" angezeigt wird, 
müssen Sie auf OK klicken, damit die Schnittstelle auf dem System 
registriert wird.
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 7
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3 Starten Sie Agilent VEE Pro oder Agilent VEE Express, sofern Sie 
dies nicht bereits getan haben. Klicken Sie in der Symbolleiste auf 
das Symbol Instrument Manager .

4 Das Dialogfenster Instrument Manager wird angezeigt. Klicken Sie 
auf die Schaltfläche Find Instruments, damit automatisch alle Instru-
mente ermittelt und konfiguriert werden, die an den PC ange-
schlossen sind. Klicken Sie auf Yes, wenn das Dialogfenster Identify 
Instrument angezeigt wird. Dadurch wird das Instrument an der 
USB- Schnittstelle automatisch erkannt (identifiziert). In diesem 
Beispiel ist ein Digitalmeßinstrument Agilent 34410A vorhanden.

5 Wählen Sie im Bereich "Instrument List" den Eintrag für das neue 
Instrument (newInstrument) aus. Klicken Sie dann im Bereich 
"Create I/O Object" auf Direct I/O, damit im Arbeitsbereich ein 
Direct I/O- Objekt für das neue Instrument angeordnet wird. 
Über dieses Objekt können Sie Befehle an das/vom Instrument 
senden/empfangen.

6 Doppelklicken Sie auf die blaue Transaktionsleiste des Direct 
I/O- Objekts, damit Sie ihm eine Transaktion hinzufügen können.
8 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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7 Geben Sie im Dialogfenster I/O Transaction die Zeichenfolge "*IDN?" 
ein. Geben Sie auch die Anführungszeichen ein (siehe Abbildung). 
Klicken Sie zum Fortsetzen auf OK.

*IDN? ist einer der SCPI- Befehle (Standard Commands for 
Programmable Instruments). Dieser Befehl fragt ein Instrument 
nach dessen Identifikationsszeichenfolge ab.

8 Nach dem Senden der Abfrage "*IDN?" an das Instrument muss 
dessen Antwort gelesen werden. Doppelklicken Sie auf das Textfeld 
des newInstrument- Objekts, damit Sie eine neue Transaktion hin-
zufügen können. Wählen Sie für diese Transaktion aus, dass sie mit 
einem READ- Befehl Text im STRING FORMAT lesen und an einen Aus-
gabeanschluss (output terminal, Ausgang) mit dem Namen x senden 
soll. Der Ausgang x wird automatisch erstellt, sobald Sie auf OK 
geklickt haben.
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 9
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9 Wählen Sie Display > AlphaNumeric aus, und ordnen Sie ein 
AlphaNumeric- Objekt im Arbeitsbereich rechts neben dem Direct 
I/O- Objekt an.

10 Das Direct I/O- Objekt soll nun  mit dem AlphaNumeric- Objekt ver-
bunden werden. Platzieren Sie den Cursor neben dem Ausgang des 
Direct I/O- Objekts. Es wird ein quadratisches Symbol angezeigt. 
Klicken Sie mit der linken Maustaste, und ziehen Sie eine Linie 
zum Eingabeanschluss (input terminal, Eingang) des AlphaNumeric-
Objekts. Klicken Sie erneut mit der linken Maustaste, um die Ver-
bindung abzuschließen.

11 Führen Sie das Programm aus, indem Sie in der Symbolleiste auf 
das Symbol Run klicken.

12 Das AlphaNumeric- Objekt zeigt die Identifikationszeichenfolge an, 
die das Instrument ausgegeben hat (siehe folgende Abbildung).

13 Zum Speichern des VEE- Codes wählen Sie File > Save As aus. Geben 
Sie der Datei den Namen Uebungseinheit 1.vee.
10 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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Virtuelle Quelle (Virtual Source) - Übungseinheit
In dieser Übungseinheit generieren Sie eine Wellenform aus einer 
virtuellen Quelle und zeigen diese Wellenform an. Es ist kein Instru-
ment erforderlich.

1 Wenn im Arbeitsbereich von Agilent VEE Pro oder Agilent VEE 
Express ein Programm vorhanden ist, wählen Sie File > New aus. 
Wählen Sie dann Device > Virtual Source > Function Generator aus, und 
ordnen Sie im Arbeitsbereich ein Function Generator- Objekt an.

2 Der Funktionsgenerator erzeugt standardmäßig eine virtuelle 
Cosine- Wellenform (Kosinus) mit der Frequenz (Frequency) 200 Hz 
und der Amplitude 1. 
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 11
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3 Wählen Sie Display > XY Trace aus, und legen Sie ein XY 
Trace- Objekt rechts neben dem Function Generator- Objekt ab. 

4 Verbinden Sie den Ausgang des Function Generator- Objekts mit 
dem Eingang des XY Trace- Objekts. Platzieren Sie den Mauscursor 
neben dem Ausgang des Function Generator- Objekts. Es wird ein 
quadratisches Symbol angezeigt. Klicken Sie mit der linken Maus-
taste, und ziehen Sie eine Linie zum Eingang des XY Trace- Objekts. 
Klicken Sie erneut mit der linken Maustaste, um die Verbindung 
abzuschließen.

5 Klicken Sie in der Symbolleiste auf das Symbol Run . Danach 
wird die Kosinuswellenform im XY Trace- Objekt angezeigt. 
12 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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6 Wählen Sie Display > Spectrum (Freq) > Magnitude Spectrum aus, und 
legen Sie im Arbeitsbereich ein Magnitude Spectrum- Objekt unter 
dem XY Trace- Objekt ab.

7 Ziehen Sie gemäß der in Schritt 4 beschriebenen Methode des 
Linksklickens und Ablegens eine zweite Linie vom Ausgang des 
Function Generator- Objekts zum Eingang des Magnitude 
Spectrum- Objekts.

8 Klicken Sie auf das Symbol Run , und sehen Sie sich die 
Anzeige des Magnitude Spectrum- Objekts an. Da die Wellenform 
einer 200- Hz- Kosinuswelle entspricht, zeigt das Magnitude 
Spectrum- Objekt eine vertikale Linie bei der Frequenz 200 Hz an.
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 13
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9 Ändern Sie die Funktion im Generator für virtuelle Funktionen in 
eine rechteckige (Square) Wellenform. 
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10 Klicken Sie auf das Symbol Run , und sehen Sie sich den 
Unterschied an. Agilent VEE bietet Ihnen die Möglichkeit, eine 
Signalquelle gleichzeitig in mehreren Grafikdarstellungen zu 
analysieren. 

11 Zum Speichern des VEE- Codes wählen Sie File > Save As aus. Geben 
Sie der Datei den Namen Uebungseinheit 2.vee
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 15
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Unterschiede zwischen Agilent VEE Pro und Agilent VEE 
Express

In der folgenden Tabelle sind die Unterschiede zusammengestellt, die 
es zwischen Agilent VEE Pro und Agilent VEE Express gibt.

Funktionen Agilent VEE Pro Agilent VEE 
Express

Schnittstellen GPIB, LAN, 
RS- 232, VXI, PXI, 

SCXI

USB
(Agilent 

USB- Geräte nur in 
LiveMode)

MatlabScript- Objekte und Matlab-
Script- Modul

Erstellen von Laufzeitversionen von 
Agilent VEE- Programmen und geschütz-
ten (secured) Versionen von Agilent 
VEE- Objekten

Programmgesteuertes Ändern von 
Instrumentenadressen

Funktion "Aufrufbarer Server" (Callable 
Server), d. h., Agilent VEE kann als 
ActiveX- Automatisierungsserver aufge-
rufen werden

Verwenden von fernen Funktionen, d. h., 
es können Benutzerfunktionen impor-
tiert werden, die in einem anderen 
Agilent VEE- Prozess auf einem fernen 
Hostcomputer ausgeführt werden

Weitere Funktionen
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VEE8_QSG.book  Page 17  Monday, March 12, 2007  3:40 PM
Neue Eigenschaften von Agilent VEE Pro 8.0 und Agilent 
VEE Express 8.0

Neuer Ausführungsmodus und neue Datentypen: Ab Version 8.0 unterstützt 
Agilent VEE zwei neue Datentypen (Int64 und Boolean) sowie einen neuen 
Ausführungsmodus (VEE 8).

Watch Window: Diese leistungsfähige Kompo-
nente für das Debuggen versetzt Sie in die 
Lage, bei der Fehlersuche die Werte von 
Variablen und Leitungen/Anschlüssen 
(Terminals) anzuzeigen und zu bearbeiten. 
Die Ausführung des jeweiligen Programms 
kann fortgesetzt werden, wobei alle geän-
derten Werte berücksichtigt werden.

Minimap: Ihre Objekte kommen Ihnen im Arbeitsbereich nie mehr 
abhanden! Diese Komponente ermöglicht Ihnen einfaches Navigieren in 
einer umfangreichen Detailansicht. Über diese Komponente können Sie 
außerdem ein in der Größe geändertes Bild der Detailansicht drucken. 
Minimap hat ein umfangreiches Kontextmenü. Sie können die jeweilige 
Minimap über das Kontextmenü kopieren, drucken, speichern oder als 
E- Mail senden.

Code Completion und Code Insight (Codevervoll-
ständigung und Codeeinblick): Diese leis-
tungsfähige neue Eigenschaft bietet große 
Vorteile für alle, die Formeln schreiben. Die 
Eigenschaft verringert die Tastatureingaben 
und führt dazu, dass Sie sich nicht so exakt 
erinnern müssen und meist auf die externe 
Dokumentation verzichten können. Sie kön-
nen im aktuellen Kontext bleiben, nach den benötigten Informationen 
suchen, Sprachelemente direkt in Formeln einfügen und sogar Agilent VEE 
dazu veranlassen, die jeweilige Eingabe für Sie abzuschließen.

Programmgesteuerte Eigenschaften: Diese leistungsfähige neue Funktion 
ermöglicht es Ihnen, Farbe, Titel, Größe, Position sowie viele weitere 
Eigenschaften von Agilent VEE- Objekten, .NET- Objekten oder COM- Objek-
ten programmgesteuert (zur Laufzeit) zu ändern. So können Sie einfacher 
und schneller bessere grafische Agilent VEE- Benutzeroberflächen erstellen!
Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung 17
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Aktualisierte NIDAQ-Unterstützung zum Einbinden von NIDAQmx-Treibern: Ab 
Agilent VEE Pro 8.0 kann Instrument Manager Instrumente mit 
NIDAQmx- Treibern automatisch finden.

Geräte nach VISA-Standard: Ersetzen Sie ältere inkonsistente E/A- Geräte 
(SICL und VISA gemischt) durch einen einheitlicheren Ansatz, wenn Sie 
E/A- Geräte  (I/O Devices) deklarieren oder verwenden. Abwärtskompati-
bilität bleibt erhalten, obwohl den Benutzern empfohlen wird, Geräte nach 
neuem Standard zu verwenden.

Erweiterungen der Aufzeichnungsnutzbarkeit: Diese neue Eigenschaft bietet 
schnellere und einfachere Methoden zum Deklarieren, Erstellen und 
Löschen von Aufzeichnungsvariablen oder - konstanten. Die neue inte-
grierte Funktion "buildRecord()" ermöglicht es Ihnen, eine Aufzeichnung 
zu erstellen, indem Sie die Feldnamen und die Feldwerte zur Laufzeit 
angeben.

Mehrere Spuren (Traces) in Graph-Objekten über einen Eingangsstift (input pin) 
anzeigen: Diese Eigenschaft versetzt Sie in die Lage, mit den Agilent VEE 
Graph- Objekten mehrere Spuren (ein Array aus Spuren) anzuzeigen, ohne 
im Voraus zu wissen, wie viele Spuren vorhanden sein werden.

Bildlauf (Scrollen) in der Bildschirmansicht ermöglichen: Es kann festgelegt 
werden, dass automatisch Bildlaufleisten (ScrollBars) angezeigt werden, 
wenn die Bildschirmansicht (panel view) zu klein ist, um alle Objekte 
anzuzeigen. Diese Funktion kann ein-  oder ausgeschaltet werden, indem 
die Bildschirmeigenschaft "ScrollbarsEnabled." geändert wird. Die  
Standardeinstellung ist "Off". 

Erweiterungen über mehrere Transaktionen: Hiermit werden alle transaktions-
basierten Agilent- Objekte (z. B. "Direct I/O") erweitert. Sie können nun 
einfach mit den Standardtastenkombinationen viele Operationen (Kopie-
ren, Löschen, Auswählen usw.) für mehrere Transaktionen ausführen 
sowie Transaktionen in der Liste nach oben oder unten verschieben.

Home: In Agilent VEE 8.0 wurde der Symbolleiste ein neues Symbol  
hinzugefügt, über das die obere linke Ecke des Programmbereichs in die 
obere linke Ecke des Arbeitsbereichs (Main, UserFunctions oder 
UserObjects) verschoben werden kann.

Neue Instrumentenbeispiele: In examples\instrumentIO\
InstrumentManagerIntergrated wurden viele Instrumentenbeispiele 
geändert und viele neue Beispiele hinzugefügt.
18 Agilent VEE Pro 8.0 und Agilent VEE Express 8.0 - Kurzanleitung
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Agilent-Konnektivitätsprodukte

Agilent bietet eine umfassende Palette von sehr leistungsfähigen und 
zuverlässigen Produkten an, über die PCs mit Instrumenten verbun-
den werden können. Dazu gehören ein netzwerkbasierter USB- Hub, 
ein LAN/GPIB- Gateway sowie PCI/GPIB- , USB/GPIB-  und 
USB/RS232- Schnittstellen. Weitere Informationen zu den Konnektivi-
tätsprodukten von Agilent finden Sie hier: www.agilent.com/find/io.

Agilent-Unterstützung, -Dienstleistungen und -Aktualisie-
rung

Mit Agilent VEE Pro und Agilent VEE Express haben Sie Zugriff auf 
die weltweiten Agilent- Ressourcen für die Erstunterstützung, für 
Schulungen und für Aktualisierungen. Mit dem Kauf irgendeines 
Agilent VEE- Produkts erwerben Sie das Recht, kostenfreie technische 
Unterstützung zu erhalten. Eine Registrierung ist nicht erforderlich. 

Agilent bietet weitere Beratungsdienstleistungen an. In den USA, in 
Europa und im Nahen Osten gibt es momentan mehr als 30 Unter-
nehmen, von denen Sie beim Entwickeln von Agilent VEE- Lösungen 
unterstützt werden können.

Melden Sie sich für die elektronische Agilent VEE- Benutzergruppe 
unter http://www.agilent.com/find/vrf an. Hier erhalten Sie von 
Experten auf der ganzen Welt Hilfe zum Arbeiten mit Agilent VEE.

E5810A E5805A 10833X 82350B 82.357B
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Anhang
Die Hilfe von VEE Pro 8.0 ist jetzt in verschiedenen Sprachen verfüg-
bar. Um die Sprache zu ändern, müssen Sie die Datei vee.chm in 
Ihrem Installationsverzeichnis zunächst in veeEnglish.chm umbenen-
nen. Anschließend ändern Sie den Namen der gewünschten lokalen 
Version von z.B. veeGerman.chm in vee.chm. 
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はじめに

VEE Proファミリにようこそ！ Agilent VEE（Visual Engineering Environment）

は、開発時間の大幅な短縮を可能にするパワフルなビジュアル・プログラミング

環境です。本書は、Agilent VEEの入門ガイドです。Agilent VEEのインストール

の仕方と使用方法について説明します。 本書には、USBインタフェース経由での測

定器との通信方法と波形の作成／表示方法を示した2つのチュートリアルが含ま

れています。

Agilent IO Librariesのインストール

Agilent IO Libraries Suite software は、Agilent VEE Pro またはAgilent VEE

Expressを購入した際に付属しています。このソフトウェアにより、測定器とシリ

アル、USB、GPIB、またはLANインタフェース経由で通信が行えるようになります。

以下のインストール手順に従ってください。

1 Agilent IO Library Suites CDをCD- ROMドライブに挿入します。Agilent IO
Libraries Suite 14.2ウィンドウの Install Softwareをクリックしてインストール

を開始します。

2 InstallShield® Wizardの指示に従ってインストール処理を進めます。Nextをク

リックしてデフォルト設定を受け入れ、インストールを完了します。
2 Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド
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3 Agilent Connection Expert ウィンドウが表示されます。このアプリケーショ

ンで、PCに接続されている測定器の設定を行います。ウィンドウを閉じて、次

のステップに進みます。
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Agilent VEE ProまたはAgilent VEE Expressのインストール

1 Agilent VEEインストールCDを挿入し、Install Agilent VEE Pro Development、ま

たは Install Agilent VEE Express を選択します。InstallShield® Wizard の指示に

従ってインストール処理を進めます。 

「これらの製品の違いに関して、ページ１６を参照してください」

2 InstallShield® Wizardが、Microsoft .NET Framework 2.0がインストールされ

ているかチェックします。インストールされていない場合、以下のメッセージ・

ボックスが表示されます。 

Microsoft .NET Framework 2.0をインストールしたら、InstallShield® Wizardの

指示に従ってステップ1のAgilent VEE選択に対するインストール処理を進めま

す。
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3 ライセンス契約を承諾し、Nextをクリックします。

4 Customer Informationダイアログ・ボックスが表示されたら、名前、会社名、

製品キーを入力します。 製品キーは、Agilent VEE Pro またはAgilent VEE
Express Product Key Certificateに記載されています。Nextをクリックして

デフォルト設定を受け入れます。Typical Setupが表示されたらそれを選択し、イ

ンストールを完了します。
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Agilent VEE ProまたはAgilent VEE Expressの起動

All Programs > Agilent VEE Pro 8.0> VEE Pro 8.0 またはAll Programs > Agilent VEE
Express 8.0> VEE Express 8.0に進んでAgilent VEE ProまたはAgilent VEE Express

を起動します。

Agilent VEE ProまたはAgilent VEE Expressのようこそウィンドウからチュー

トリアル、MATLABデモ（Agilent VEE Proでのみ使用可能）、サンプル・プログラ

ムにアクセスできます。 メニューを確認してからウィンドウを閉じます。

サンプル・プログラムは、メニュー・バーからもオープンできます。サンプル・

プログラムを開くには、File > Open Exampleに進みます。

ようこそ

画面

プログラ

ム・エクス

プロパ

ティ・ウィ

ツール・

バー

ステータス・

バー

メニュー・

バー

ワークスペース
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測定器通信チュートリアル

このチュートリアルでは、USBインタフェース経由で測定器に接続します。 作業を

進める前にAgilent IO Libraries Suite 14.2がインストールされていることを確認して

ください。 

USB測定器がない場合、GPIB測定器のチュートリアルはステップ3からほぼ同じで

す。 

次に示すのは、Agilent VEE Proのインストールの場合のスクリーン・ショット

です。Agilent VEE Expressでも同様のスクリーン・ショットが得られます。

1 PCのUSBポート経由で測定器に接続します。 Found New Hardware Wizard
ダイアログ・ボックスが表示されます。ソフトウェアを検索するため、No, not
this timeを選択してWindows Updateへの接続を断ります。Nextをクリックし

て、インストールを進めます。

2 Assign USB device aliasウィンドウが表示されたら、OKをクリックしてイン

タフェースをシステムに登録する必要があります。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 7
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3 Agilent VEE ProまたはAgilent VEE Expressを起動します（起動していない場

合）。ツール・バーの Instrument Managerボタン をクリックします。 

4 Instrument Manager画面が表示されます。Find Instrumentボタンをクリックす

ると、PCに接続された測定器が自動的に検出され、設定されます（しかし、

RS-232のような測定器が高度でないインターフェースでは自動的に検出、また
は設定ができません）。Identify Instrumentプロンプトが表示されたら、Yesを

クリックします。これにより、USBインタフェース上の測定器が自動的に識別
されます。この例では、Agilent 34410Aディジタルマルティメーターが存在し

ます。

5 Instrument ListパネルでnewInstrumentを選択します。次に、Create I/O

ObjectパネルのDirect I/Oをクリックして、選択した新しい測定器のDirect I/O
オブジェクトをワークスペースに配置します。 このオブジェクトにより、測定

器とのコマンドの送受信が可能になります。

6 Direct I/Oオブジェクトの青のトランザクション・バーをダブルクリックし

て、Direct I/Oオブジェクトにトランザクションを追加します。
8 Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド
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7 下の図に示すように、I/O Transactionダイアログ・ボックスに"*IDN?"（引用

符を含む）を入力します。OKをクリックして次に進みます。

*IDN? は、測定器に識別文字列を問い合わせるStandard Commands for
Programmable Instruments（SCPI）コマンドの1つです。 

8 "*IDN?" クエリを測定器に送信したら、その応答をリードバックする必要があ

ります。 newInstrumentオブジェクトのテキスト・ボックスをダブルクリック

して、新しいトランザクションを追加します。今回は、xという名前の出力端

子へのSTRING FORMATテキストをREADするためのトランザクションを選択し

ます。OKをクリックすると、出力端子xが自動的に作成されます。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 9
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9 Display > AlphaNumericを選択し、AlphaNumericオブジェクトをワークスペース

のDirect I/Oオブジェクトの右に配置します。

10 Direct I/OオブジェクトをAlphaNumericオブジェクトに接続します。マウス

のカーソルをDirect I/Oの出力端子の横に置くと、正方形のアイコンが現れま

す。左マウス・ボタンをクリックし、AlphaNumericオブジェクトの入力端子

まで線を引きます。左マウス・ボタンをもう一度クリックして、接続を完了し

ます。

11 ツール・バーのRunボタン をクリックして、プログラムを実行します。

12 下の図に示すように、AlphaNumeric オブジェクトが、測定器によって出力さ

れた識別文字列を表示します。

13 VEEコードを保存するため、File > Save Asを選択してファイルにTutorial 1.vee

という名前を付けます。
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仮想信号源チュートリアル

このチュートリアルでは、仮想信号源から波形を作成して表示します。測定器は

不要です

1 Agilent VEE ProまたはAgilent VEE Expressのワークスペースに既存プログ

ラムが存在する場合、File > New を選択します。次にDevice > Virtual Source >
Function Generatorを選択して、ファンクション・ジェネレータ・オブジェクト

をワークスペースに配置します。

2 デフォルトで、ファンクション・ジェネレータは、周波数200 Hz、振幅1の仮
想Cosine波形を作成します。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 11
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3 Display > XY Traceを選択し、XY Traceオブジェクトをファンクション・ジェネ

レータの右に配置します。 

4 ファンクション・ジェネレータの出力端子をXY Traceの入力端子に接続しま

す。マウスのカーソルをファンクション・ジェネレータの出力端子の横に置く
と、正方形のアイコンが現れます。左マウス・ボタンをクリックし、XY Trace

オブジェクトの入力端子まで線を引きます。左マウス・ボタンをもう一度ク

リックして、接続を完了します。

5 ツール・バーのRunボタン をクリックすると、XY Traceオブジェクトに

コサイン波形が表示されます。 
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6 Display > Spectrum (Freq) > Magnitude Spectrumを選択し、Magnitude Spectrum

オブジェクトをワークスペースのXY Traceオブジェクトの下に配置します。

7 ファンクション・ジェネレータの出力からMagnitude Spectrumオブジェクト

の入力に、ステップ4で説明した左マウス・ボタンのクリックおよびドラッグ

と同じ方法で2番目のラインを接続します。

8 Runボタン をクリックし、振幅スペクトラム表示を観察します。波形は

200 Hzコサインであるため、振幅スペクトラムとして周波数200 Hzに縦線が

表示されます。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 13
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9 仮想ファンクション・ジェネレータの波形機能を方形波に変更します。 
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10 Runボタン をクリックし、違いを観察します。 Agilent VEEを使用すると、

信号源を同時に複数のグラフに表示してさまざまな解析が行えます。 

11 VEEコードを保存するため、File > Save Asを選択してファイルにTutorial 2.vee

という名前を付けます。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 15
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Agilent VEE ProとAgilent VEE Expressの違い

以下の表に、Agilent VEE ProとAgilent VEE Expressの相違点を示します。

機能 Agilent VEE Pro Agilent VEE Express

インタフェース GPIB、LAN、RS-232、

VXI、PXI、SCXI

USB

（LiveModeのAgilent 

USBデバイスのみ）

MatlabScriptオブジェクトおよびMatlabScript

エンジン

Agilent VEE プログラムのランタイム・バージョ

ンとAgilent VEEオブジェクトのセキュア・バー

ジョンの作成

測定器アドレスのプログラムによる変更

Agilent VEEをActiveXオートメーション・サーバ

として呼び出すなどの呼び出し可能サーバ機能

リモート・ホスト・コンピュータの別のAgilent

VEEプロセスで実行するUserFunctionをインポー

トするなどのリモート関数機能

その他の機能
16 Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド
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Agilent VEE Pro 8.0/Agilent VEE Express 8.0の新機能

新しい実行モードと新しいデータ・タイプ -- Agilent VEEのバージョン8.0から、2つの新し

いデータ・タイプ Int64とBoolean、および新しい実行モードVEE 8をサポートします。

Watch Window -- デバッグ時に変数やライン／端子

の値を表示／編集できるようにする、強力なデバッ

グ機能です。 プログラムは、変更された値を組み込

みながら実行を継続できます。

ミニマップ -- ワークスペースでオブジェクトを見失

う心配がなくなります。 この機能を使用すると、大

規模な詳細ビューでも簡単に移動ができます。サイ

ズ変更した詳細ビュー・イメージをプリントすることも可能です。ミニマップには、パワ

フルなコンテキスト・メニューがあります。コンテキスト・メニューを使用してミニマッ

プのコピー、プリント、保存、電子メール送信が行えます。

コードの完成とコードのデバッグ -- 計算式を作成す

るときに、キーボード入力、暗記、外部文書の必要

性が減少します。コンテキストに留まる、必要な情

報を検索する、言語要素を計算式へ直接挿入する、

Agilent VEE による自動入力を設定するなどが可能で

す。

プログラマブール・プロパティ -- カラー、タイトル、

サイズ、場所などのAgilent VEEオブジェクト、.NETオブジェクト、COMオブジェクトのさ

まざまなプロパティを（ランタイム時に）プログラムによって変更することができます。

優れたAgilent VEE GUIをより簡単にすばやくビルドできます。
Agilent VEE Pro 8.0/Agilent VEE Express 8.0 クイック・スタート・ガイド 17
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NIDAQmxドライバが含まれるようにNIDAQサポートをアップデート -- Agilent VEE Pro 8.0か

ら、Instruments ManagerがNIDAQmxドライバを持つ測定器を自動的に検出できます。

VISAスタイルのデバイス -- I/Oデバイスの宣言または使用の方法を（VISAに）より統一化

するため、古い一貫性のない I/Oデバイス（SICLとVISAの混在）を段階的に廃止します。

新しいスタイルのデバイスを使用するよう「推奨」しますが、以前の製品との互換性は保

持されます。

レコード・ユーザビリティの機能拡張 -- レコード変数やレコード定数の宣言、ビルド、ア

ンビルドがより簡単に行える方法を提供します。新しい組込み関数 buildRecord()を使用す

ると、ランタイム時にフィールド名とフィールド値を指定すればレコードをビルドできま

す。

1本の入力ピンから、Graphオブジェクトで複数のトレースを表示 -- 前もって何本のトレー

スになるかを知らずに、Agilent VEE Graphオブジェクトを使って複数のトレース（トレー

スの配列）を表示できます。

パネル・ビューのスクロールが可能 -- サイズの関係でパネル・ビューにすべてのオブジェ

クトを表示できない場合、スクロール・バーが自動的に表示されるように設定できます。

この機能のオンとオフを切り替えるには、"ScrollbarsEnabled"というパネル・プロパティを

変更します。デフォルトはオフです。 

複数のトランザクション機能拡張 -- Agilent VEEトランザクション・ベース・オブジェクト

（Direct IOなど）をすべて機能拡張します。複数トランザクションでさまざまな操作（コ

ピー、削除、選択など）を実行したり、標準のキーボード・ショートカットを使用してリ

スト内でトランザクションを上下に簡単に移動したりすることができます。

ホーム -- Agilent VEE 8.0で新しいツールバー・ボタン が追加されました。このボタン

を押すと、プログラムの左上隅がワーク・エリア（Main、UserFunctions、UserObjects）の

最上部左隅まで移動します。

新しい測定器サンプル -- examples\instrumentIO\InstrumentManagerIntegrated の多くの測定

器サンプルを更新し、新しい測定器サンプルも多数追加しました。 
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Agilentコネクティビティ製品

Agilentでは、PCと測定器を接続するための高性能で信頼性の高い製品を多数揃え

ています。ネットワークUSBハブ、LAN/GPIBゲートウェイ、PCI GPIBインタフェー

ス、USB/GPIBインタフェース、USB/RS232インタフェースなどの製品があります。

Agilentコネクティビティ製品の詳細については、www.agilent.com/find/ioをご覧

ください。

Agilentのサポート、サービス、アシスタンス

Agilent VEE Pro/Agilent VEE Expressの使用中、Agilentの世界規模のリソース

にアクセスして、セットアップ・アシスタンス、トレーニング・クラス、アップ

デート・サービスを利用することができます。Agilent VEE製品の購入の一部とし

て、テクニカル・サポートが無料でご利用いただけます。登録の必要はありません。 

Agielntではその他のコンサルティング・サービスも行っています。現在、北米、

ヨーロッパ、中東、アジアの30を超える国でAgilent VEEソリューションの開発

に対するサポートを提供しています。

Agilent VEE電子ユーザ・グループ（http://www.agilent.com/find/vrf）に登録

すると、世界各国のエキスパートからAgilent VEEの使用に関するサポートが得ら

れます。

E5810A E5805A 10833X 82350B 82357B
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ふろく

ただいま、Agilent VEE Pro 8.0ヘルプは他の言語にでも提供されていま
す。インストール・ディレクトリでは、もともとの vee .chm を
veeEnglish.chmに変え、そして、vee.chmは好きな言語バージョンの名前
を変えてください。 たとえば、veeJapanese.chmをvee.chmに変え、日本
語のヘルプ表示をできます。
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简介

欢迎使用 Agilent VEE! 安捷伦可视化工程环境 (VEE) 是一个功能强大的开
发环境，它可以有效且显著的缩短你的开发时间。本手册将通过介绍如何安
装和使用 Agilent VEE 使你能更快地开始使用 Agilent VEE，并且通过两个
范例向你介绍如何通过 USB 接口与仪器进行通信以及如何使用虚拟信号源
产生和显示一个波形。

安装 Agilent IO 库

在你购买 Agilent VEE Pro 或 Agilent VEE Express 时， 将同时免费获得
Agilent IO 库软件。 该软件可以查找、识别和配置通过串行接口、 USB 接
口、 GPIB 接口或 LAN 连接到你计算机上的所有仪器。请按下列步骤安装
Agilent IO 库。

1 将 Agilent IO Library Suites 光盘插入光盘驱动器。 当 Agilent IO 
Libraries Suite 14.2 窗口出现后，单击 Install Software 按钮开始安
装。
2 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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2 InstallShield® Wizard 将指导你完成整个安装过程。单击 Next 按钮，并
使用全部缺省设置直到安装完成。

3 安装完成后，你将看到如下所示欢迎窗口。浏览过该窗口后，你可以将
它关闭。 
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 3
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安装 Agilent VEE Pro 或 Agilent VEE Express
1 将 Agilent VEE installation CD 插入光盘驱动器。安装文件将自动打

开。单击 Install Agilent VEE Pro Development 或 Install Agilent 
VEE Express 按钮。 InstallShield® Wizard 将指导你完成整个安装过
程。 

有关上述产品间的区别，请参阅第 16 页。

2 首先， InstallShield® Wizard 会检查你是否已安装了 Microsoft .NET 
Framework 2.0。如果没有安装，你将看到下面的对话框，请单击 OK 按
钮开始安装。

当 Microsoft .NET Framework 2.0 安装完毕后， InstallShield® Wizard
会继续指导你完成你在第一步中所选择的 Agilent VEE 产品的安装。
4 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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3 当 License Agreement 对话框出现后，选择接受版权协议，并单击 Next
按钮。

4 当 Customer Information 对话框出现后，请输入你的姓名、公司名称以
及产品序列号（可以在 Agilent VEE Pro 或 Agilent VEE Express 的产
品序列号证书中找到产品序列号）。接受缺省设置并单击 Next 按钮。当
提示出现时，选择 Typical Setup。继续单击 Next 按钮直到安装完成。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 5
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运行 Agilent VEE Pro 或 Agilent VEE Express
从 All Programs > Agilent VEE Pro 8.0> VEE Pro 8.0 或 All 
Programs > Agilent VEE Express 8.0> VEE Express 8.0 可以打开
Agilent VEE Pro 或 Agilent VEE Express。下图为打开 Agielnt VEE Pro 
时的主界面。

在欢迎画面中，你可以选择查看 VEE 的介绍、 VEE 新功能的介绍、范例程
序、辅导教程或 MATLAB 演示程序。浏览过该窗口后，你可以将它关闭。

你可以从菜单栏 Help > Contents and Index 查看帮助文件，也可以从菜
单栏 File > Open Example 打开范例程序。

欢迎
画面

程序
浏览区

属性窗口

工具栏

状态栏

菜单栏

工作区
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仪器通信范例

在本范例中 , 我们将介绍如何通过 USB 接口与仪器进行通信。开始前，请确
认 Agilent IO Libraries Suite 14.2 已经安装。 

如果你没有 USB 仪器，那么从第三步开始本范例也适用于 GPIB 仪器。 

下面的截图都来自 Agilent VEE Pro。 Agilent VEE Express 的截图与此
类似。

1 将仪器通过 USB 接口连接到你的计算机上。 然后，打开电源。当 Found 
New Hardware Wizard 对话框出现后，单击 Next 按钮继续安装。

2 当 Assign USB device alias 对话框出现后，单击 OK 按钮将该 USB 接口
注册到你的系统中。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 7
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3 如果你还没有打开 Agilent VEE Pro 或 Agilent VEE Express，请将它打
开。然后，单击工具栏上的 Instrument Manager 按钮 。 

4 当 Instrument Manager 对话框出现后，单击 Find Instrument 按钮。
Instrument Manager 将自动检测和配置连接在你计算机上的所有仪器。
当 Identify Instrument 弹出框出现后，单击 Yes 按钮。 Instrument 
Manager 将自动识别连接在 USB 接口上的仪器。本例中，我们检测到一台
Agilent 34410A 数字万用表。

5 在 Instrument List 框中选择 newInstrument。然后，在 Create I/O 
Object 框中单击 Direct I/O 按钮，这将为这个已经选择好的仪器
（newInstrument）产生一个 Direct I/O 对象。将该对象放置在工作区
中。 使用该对象你可以向仪器发送命令并接收来自仪器的数据。
8 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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6 双击该 Direct I/O 对象的蓝色事务条 <Double- Click to Add 
Transaction> 打开 I/O 事务对话框以增加一个事务到该对象。

7 在 I/O事务对话框中按下图所示输入 "*IDN?" (包括引号 ) 。然后单击OK 
按钮继续。 *IDN? 是一个用于可编程仪器的标准命令 (SCPI)。 用它可查
询仪器的识别码。

8 发出 "*IDN?" 查询后，你还需把查询结果读回来。双击 newInstrument 
的 Direct I/O 对象的事务条 <Double- Click to Add Transaction> 再增
加一个新事务。 这次，如下所示，选择 READ 一个 STRING FORMAT 
到输出端 x。 单击 OK 按钮后，输出端 x 将自动产生。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 9
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9 从菜单栏选择 Display > AlphaNumeric，并将 AlphaNumeric 对象放在
工作区中 Direct I/O 对象的右边。

10 下面我们将把 Direct I/O 对象和 AlphaNumeric 对象连接起来。将鼠标
光标放在 Direct I/O 对象数据输出端的附近。当出现一个小方块时，单
击鼠标左键。移动鼠标会出现一条线，将这条线拖到 AlphaNumeric 对
象的数据输入端。再次单击鼠标左键完成该连接。

11 单击工具栏的 Run 按钮 运行该程序。

12 如下所示， AlphaNumeric 对象将显示由仪器输出的识别串。

13 如要保存你的VEE 代码，请选择File > Save As 并将其命名为Tutorial 
1.vee。
10 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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虚拟信号源范例

在本范例中，你将学习使用虚拟信号源来产生并显示一个波形。本范例不需
要使用仪器。

1 打开Agilent VEE Pro或Agilent VEE Express后，选择File > New开始
一个新的 VEE 程序。然后，选择 Device > Virtual Source > Function 
Generator 生成一个波形发生器对象。将该对象放置在工作区中。

2 缺省状态下，该波形发生器将产生一个虚拟的余弦波，它的频率是 200 
Hz, 幅度是 1。 
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 11
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3 选择 Display > XY Trace 生成一个 XY Trace 对象，将该对象放置在波
形发生器的右边。 

4 将波形发生器对象的数据输出端连接到 XY trace 对象的数据输入端。将
鼠标光标放在 Direct I/O 对象数据输出端的附近。当出现一个小方块
时，单击鼠标左键。移动鼠标会出现一条线，将这条线拖到 XY trace 对
象的数据输入端。 再次单击鼠标左键完成该连接。

5 单击工具栏上的Run按钮 ， 你将会看到在XY Trace 对象中显示的
余弦波。 
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6 选择 Display > Spectrum (Freq) > Magnitude Spectrum 生成一个
Magnitude Spectrum 对象，将该对象放置在工作区中 XY Trace 对象的
下面。

7 从 Function Generator 对象的数据输出端拉出第二条线连到 Magnitude 
Spectrum 对象的数据输入端。请参阅第 4 步中所描述的单击和拖拽的方
法。

8 单击 Run  按钮并观察 Magnitude Spectrum 中的显示情况。 因为
这是一个200 Hz 的余弦波形，Magnitude Spectrum 将在频率为 200 Hz 
处显示一条垂线。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 13
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9 如下图所示，将虚拟波形发生器变为方波。
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10 单击 Run 按钮  并观察 Magnitude Spectrum 中显示的变化。
Agilent VEE 可以同时显示多个图形以便于进行信号源分析。

11 如要保存你的VEE 代码。请选择File > Save As 并将其命名为Tutorial 
2.vee。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 15
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Agilent  VEE Pro 和 Agilent  VEE Express 的区别

下表列出了 Agilent VEE Pro 和 Agilent VEE Express 的区别。

功能 Agilent  
VEE Pro

Agilent 
VEE Express

接口 GPIB、 LAN、
RS- 232、 VXI、

PXI、 SCXI

USB
( 只支持已通过 USB
接口连接且已加电的

安捷伦设备 )

MatlabScript 对象和 MatlabScript 引擎

创建 Agilent VEE 程序的运行版本和
Agilent VEE 对象的安全版本

运行时动态修改仪器地址

可调用服务器功能，即将按捷伦 VEE 作为
一个 ActiveX Automation 服务器来调用

远程函数调用功能 ,即调用一个运行在远程
主机上的 Agilent VEE 进程中的
UserFunction

其他功能
16 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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Agilent  VEE Pro 8.0 和 Agilent  VEE Express 8.0 的新功能

新的执行模式和新的数据类型 -- 从 8.0 版开始， Agilent VEE 将增加支持两种
新的数据类型 -  Int64 和 Boolean 以及一个新的执行模式 -  VEE 8。

Watch Window -- 使用这个功能强大的调试工
具，用户可以在调试时查看并修改变量或输入
输出端的值并使用修改后的值继续执行。

Minimap -- 再也不用因为在工作区中找不到对
象而烦恼了。这一新功能可以让用户轻而一举
地浏览一个很大的详细视图并快速地定位到某
一区域。另外，使用 Minimap 的上下文菜单，
用户可以打印、复制、保存程序的详细试图，并可将详细视图作为附件通过电子
邮件发送。

Code Completion and Code Insight-- 这一新功能可
以帮助减少键盘输入和对大量文档的查找与记
忆。无需离开上下文，你就可以快速准确地在
Formula 中编写程序语句。你甚至可以让
Agilent VEE 替你完成输入。

Programmatic Properties -- 这一新功能可以让用
户更快速地建立更完美的 Agilent VEE 用户界
面。用户可以在运行时动态地改变各种对象的颜色、标题、大小、位置及其他许
多属性。这些对象包括安捷伦的 VEE 对象、 .NET 对象和 COM 对象。
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 17
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增加了对 NIDAQmx 的支持 -- 从 Agilent VEE Pro 8.0 开始，仪器管理器就可以
自动找到使用 NIDAQmx 驱动程序的仪器了。

VISA 型设备 -- Agilent VEE 8.0 开始采用统一的方法 (VISA) 来声明和使用 I/O 
设备，旧的不一致的 I/O 设备的声明和使用方法（一些设备使用 SICL 方法，一
些设备使用 VISA 方法）将被逐渐淘汰。虽然我们鼓励用户使用新型的设备，但
是我们仍会对旧设备提供兼容支持。

增强的 Record 使用功能 -- 这个新功能为声明，创建和拆分纪录变量和常数提供
了一个快速便捷的方法。另外，使用新的内置函数 buildRecord()，用户还可以
在运行时指定域名和域值来动态地创建一个记录。

在一个图形对象上通过一个输入端显示多条轨迹 -- 这一功能可以让用户在事先
不知道将要显示的轨迹的数目时，也能在 Agilent VEE 的图形对象上动态地将
这些轨迹 (一组轨迹 )显示出来。

面板视图中新增了滚动条 -- 当面板视图不足以放下所有的对象时，滚动条会自
动出现。通过改变面板对象的 "ScrollbarsEnabled" 属性可以将这一功能打开或
关闭。缺省值是关闭。

增强的多事务操作功能 -- 本功能增强了所有基于事务的 Agilent VEE 对象 （比
如 Direct IO) 的操作。现在，用户不仅可以使用标准的快捷键对多个事务同时
进行诸如复制、删除和选择等许多操作，还可以使用标准的快捷键对事务进行上
移和下移。

Home -- Agilent VEE 8.0 添加了一个新的 工具栏 按钮  。它可以将 VEE 程序
的左上角快速地移到工作区 (Main, UserFunctions, 或 UserObjects) 的左上角。

新添加的仪器范例 -- 可以在 examples\instrumentIO\
InstrumentManagerIntergrated 处找到新添加的仪器范例。
18 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册
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安捷伦连接转换类产品

安捷伦提供了一整套高性能、高可靠性的产品用于连接你的计算机和仪器。
这些产品包括网络 USB 集线器、 LAN/GPIB 网关、 PCI GPIB、
USB/GPIB和USB/RS232转换接口。了解更多有关安捷伦连接转换类产品的
信息，请访问 www.agilent.com/find/io。

安捷伦的技术支持和服务
购买了 Agilent VEE Pro 或 Agilent VEE Express，您就拥有了包括启动
协助，培训课程和升级服务在内的安捷伦全球范围内的服务资源。 作为购
买安捷伦产品的一部分 ,您也将无需注册就获得免费的技术支持。

此外，您还将获得安捷伦提供的咨询服务。目前，分布在北美、欧洲、中东
及亚洲的 30 多家公司将协助您完成 Agilent VEE 解决方案的开发。

立即访问 http://www.agilent.com/find/vrf 并注册成为 Agilent VEE 电子
用户组成员，您就可以随时与世界各地的 Agilent VEE 专家探讨有关
Agilent VEE 的各种问题。

E5810A E5805A 10833X 82350B 82357B
Angilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入门手册 19
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附录
除了英文帮助文件外， Agilent VEE Pro 8.0 还提供其他语言的帮助文件。 您只
需将 Agilent VEE 安装路径下的 vee.chm 重命名为 veeEnglish.chm，再将您所
选的帮助文件命名为 vee.chm 就可以了。例如，将 veeJapanese.chm 命名为
vee.chm.
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簡介

歡迎使用 Agilent VEE! 安捷倫可視化工程環境 (VEE) 是一個功能強大的開
發環境，它可以有效且顯著的縮短你的開發時間。本手冊將通過介紹如何安
裝和使用 Agilent VEE 使你能更快地開始使用 Agilent VEE，並且通過兩個
範例向你介紹如何通過 USB 接口與儀器進行通信以及如何使用虛擬信號源
产生和顯示一個波形。

安裝 Agilent IO 庫

在你購買 Agilent VEE Pro 或 Agilent VEE Express 時， 將同時免費獲得
Agilent IO 庫軟件。 該軟件可以查找、識別和配置通過串行接口、USB 接
口、GPIB 接口或 LAN 連接到你計算機上的所有儀器。請按下列步驟安裝
Agilent IO 庫。

1 將 Agilent IO Library Suites 光盤插入光盤驅動器。 當 Agilent IO 
Libraries Suite 14.2 窗口出現後，單擊 Install Software 按鈕開始安裝。
2 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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2 InstallShield Wizard 將指導你完成整個安裝過程。單擊 Next 按鈕，並使
用全部缺省設置直到安裝完成。

3 安裝完成後，你將看到如下所示歡迎窗口。浏覽過該窗口後，你可以將
它關閉。 
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 3
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安裝 Agilent VEE Pro 或 Agilent VEE Express
1 將 Agilent VEE installation CD 插入光盤驅動器。安裝文件將自動打開。

單擊 Install Agilent VEE Pro Development 或 Install Agilent VEE 
Express 按鈕。 InstallShield Wizard 將指導你完成整個安裝過程。 

有關上述产品間的區別，請參閱第 16 頁。

2 首先，InstallShield Wizard 會檢查你是否已安裝了 Microsoft .NET 
Framework 2.0。如果沒有安裝，你將看到下面的對話框，請單擊 OK 按
鈕開始安裝。

當 Microsoft .NET Framework 2.0 安裝完畢後，InstallShield Wizard 會繼
續指導你完成你在第一步中所選擇的 Agilent VEE 产品的安裝。
4 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊



VEE8_QSG.book  Page 5  Monday, March 12, 2007  3:40 PM
3 當 License Agreement 對話框出現後，選擇接受版權協議，並單擊 Next 按
鈕。

4 當 Customer Information 對話框出現後，請輸入你的姓名、公司名稱以及
产品序列號 （可以在 Agilent VEE Pro 或 Agilent VEE Express 的产品
序列號證書中找到产品序列號）。接受缺省設置並單擊 Next 按鈕。當提
示出現時，選擇 Typical Setup。繼續單擊 Next 按鈕直到安裝完成。
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 5
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運行 Agilent VEE Pro 或 Agilent VEE Express
從 All Programs > Agilent VEE Pro 8.0> VEE Pro 8.0 或 All Programs > 
Agilent VEE Express 8.0> VEE Express 8.0 可以打開 Agilent VEE Pro 或
Agilent VEE Express。下圖為打開 Agielnt VEE Pro 時的主界面。

在歡迎畫面中，你可以選擇查看 VEE 的介紹、VEE 新功能的介紹、範例程
序、輔導教程或 MATLAB 演示程序。浏覽過該窗口後，你可以將它關閉。

你可以從菜單欄 Help > Contents and Index 查看幫助文件，也可以從菜單欄
File > Open Example 打開範例程序。

歡迎
畫面

程序
浏覽區

屬性窗口

工具欄

狀態欄

菜單欄

工作區
6 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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儀器通信範例

在本範例中 , 我們將介紹如何通過 USB 接口與儀器進行通信。開始前，請
確認 Agilent IO Libraries Suite 14.2 已經安裝。 

如果你沒有 USB 儀器，那從第三步開始本範例也適用于 GPIB 儀器。 

下面的截圖都來自 Agilent VEE Pro。Agilent VEE Express 的截圖與此類
似。

1 將儀器通過 USB 接口連接到你的計算機上。 然後，打開電源。當 Found 
New Hardware Wizard 對話框出現後，單擊 Next 按鈕繼續安裝。

2 當 Assign USB device alias 對話框出現後，單擊 OK 按鈕將該 USB 接口注
冊到你的系統中。
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 7
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3 如果你還沒有打開 Agilent VEE Pro 或 Agilent VEE Express，請將它打
開。然後，單擊工具欄上的 Instrument Manager 按鈕      。 

4 當 Instrument Manager 對話框出現後，單擊 Find Instrument 按鈕。
Instrument Manager 將自動檢測和配置連接在你計算機上的所有儀器。
當 Identify Instrument 彈出框出現後，單擊 Yes 按鈕。Instrument 
Manager 將自動識別連接在 USB 接口上的儀器。本例中，我們檢測到一
台 Agilent 34410A 數字萬用表。

5 在 Instrument List 框中選擇 newInstrument。然後，在 Create I/O Object
框中單擊 Direct I/O 按鈕，這將為這個已經選擇好的儀器
（newInstrument）产生一個 Direct I/O 對象。將該對象放置在工作區中。 
使用該對象你可以向儀器發送命令並接收來自儀器的數據。
8 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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6 雙擊該 Direct I/O 對象的藍色事務條 <Double-Click to Add Transaction>
打開 I/O 事務對話框以增加一個事務到該對象。

7 在I/O事務對話框中按下圖所示輸入 "*IDN?" (包括引號) 。然後單擊OK 按
鈕繼續。*IDN? 是一個用于可編程儀器的標准命令 (SCPI)。 用它可查詢
儀器的識別碼。

8 發出 "*IDN?" 查詢後，你還需把查詢結果讀回來。雙擊 newInstrument 的
Direct I/O 對象的事務條 <Double-Click to Add Transaction> 再增加一個
新事務。 這次，如下所示，選擇 READ 一個 STRING FORMAT 到輸出
端 x。 單擊 OK 按鈕後，輸出端 x 將自動产生。
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 9
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9 從菜單欄選擇 Display > AlphaNumeric，並將 AlphaNumeric 對象放在工
作區中 Direct I/O 對象的右邊。

10 下面我們將把 Direct I/O 對象和 AlphaNumeric 對象連接起來。將鼠標光
標放在 Direct I/O 對象數據輸出端的附近。當出現一個小方塊時，單擊鼠
標左鍵。移動鼠標會出現一條線，將這條線拖到 AlphaNumeric 對象的數
據輸入端。再次單擊鼠標左鍵完成該連接。

11 單擊工具欄的 Run 按鈕      運行該程序。

12 如下所示，AlphaNumeric 對象將顯示由儀器輸出的識別串。

13 如要保存你的 VEE 代碼，請選擇 File > Save As 並將其命名為 Tutorial 
1.vee。
10 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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虛擬信號源範例

在本範例中，你將學習使用虛擬信號源來产生並顯示一個波形。本範例不需
要使用儀器。

1 打開Agilent VEE Pro或Agilent VEE Express後，選擇File > New開始一
個新的 VEE 程序。然後，選擇 Device > Virtual Source > Function 
Generator 生成一個波形發生器對象。將該對象放置在工作區中。

2 缺省狀態下，該波形發生器將产生一個虛擬的余弦波，它的頻率是 200 
Hz, 幅度是 1。 
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 11
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3 選擇 Display > XY Trace 生成一個 XY Trace 對象，將該對象放置在波形
發生器的右邊。 

4 將波形發生器對象的數據輸出端連接到 XY trace 對象的數據輸入端。將鼠
標光標放在 Direct I/O 對象數據輸出端的附近。當出現一個小方塊時，單
擊鼠標左鍵。移動鼠標會出現一條線，將這條線拖到 XY trace 對象的數
據輸入端。 再次單擊鼠標左鍵完成該連接。

5 單擊工具欄上的 Run 按鈕      ， 你將會看到在 XY Trace 對象中顯示的
余弦波。 
12 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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6 選擇 Display > Spectrum (Freq) > Magnitude Spectrum 生成一個
Magnitude Spectrum 對象，將該對象放置在工作區中 XY Trace 對象的
下面。

7 從 Function Generator 對象的數據輸出端拉出第二條線連到 Magnitude 
Spectrum 對象的數據輸入端。請參閱第 4 步中所描述的單擊和拖拽的方
法。

8 單擊 Run     按鈕並觀察 Magnitude Spectrum 中的顯示情況。 因為這
是一個 200 Hz 的余弦波形，Magnitude Spectrum 將在頻率為 200 Hz 處
顯示一條垂線。
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 13
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9 如下圖所示，將虛擬波形發生器變為方波。
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10 單擊 Run 按鈕     並觀察 Magnitude Spectrum 中顯示的變化。Agilent 
VEE 可以同時顯示多個圖形以便于進行信號源分析。

11 如要保存你的 VEE 代碼。請選擇 File > Save As 並將其命名為 Tutorial 
2.vee。
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Agilent  VEE Pro 和 MAgilent  VEE Express 的區別

下表列出了 Agilent VEE Pro 和 Agilent VEE Express 的區別。

功能 Agilent  
VEE Pro

Agilent 
VEE Express

接口 GPIB、 LAN、
RS- 232、 VXI、

PXI、 SCXI

USB
( 只支持通過 USB 接
口連接且已加電的安

捷倫設備 )

MatlabScript 對象和 MatlabScript 引擎

創建 Agilent VEE 程序的運行版本和
Agilent VEE 對象的安全版本

運行時動態修改儀器地址

可調用服務器功能，即將按捷倫 VEE 作為
一個 ActiveX Automation 服務器來調用

遠程函數調用功能 , 即調用一個運行在遠程
主機上的 Agilent VEE 進程中的
UserFunction

其他功能
16 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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Agilent  VEE Pro 8.0 和 Agilent  VEE Express 8.0 的新功能

新的執行模式和新的數據類型 -- 從 8.0 版開始，Agilent VEE 將增加支持兩種新
的數據類型 - Int64 和 Boolean 以及一個新的執行模式 - VEE 8。

Watch Window -- 使用這個功能強大的調試工
具，用戶可以在調試時查看並修改變量或輸入
輸出端的值並使用修改後的值繼續執行。

Minimap -- 再也不用因為在工作區中找不到對
象而煩惱了。這一新功能可以讓用戶輕而一舉
地浏覽一個很大的詳細視圖並快速地定位到某
一區域。另外，使用 Minimap 的上下文菜單，
用戶可以打印、複制、保存程序的詳細試圖，並可將詳細視圖作為附件通過電子
郵件發送。

Code Completion 和 Code Insight-- 這一新功能
可以幫助減少鍵盤輸入和對大量文檔的查找與
記憶。無需離開上下文，你就可以快速准確地
在 Formula 中編寫程序語句。你甚至可以讓
Agilent VEE 替你完成輸入。

Programmatic Properties -- 這一新功能可以讓
用戶更快速地建立更完美的 Agilent VEE 用戶
界面。用戶可以在運行時動態地改變各種對象的颜色、標題、大小、位置及其他
許多屬性。這些對象包括安捷倫的 VEE 對象、.NET 對象和 COM 對象
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 17
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增加了對 NIDAQmx 的支持 -- 從 Agilent VEE Pro 8.0 開始，儀器管理器就可以
自動找到使用 NIDAQmx 驅動程序的儀器了。

VISA 型設備 -- Agilent VEE 8.0 開始采用統一的方法 (VISA) 來聲明和使用 I/O 
設備，舊的不一致的 I/O 設備的聲明和使用方法 （一些設備使用 SICL 方法，一
些設備使用 VISA 方法）將被逐漸淘汰。雖然我們鼓勵用戶使用新型的設備，但
是我們仍會對舊設備提供兼容支持。

增強的 Record 使用功能 -- 這個新功能為聲明，創建和拆分紀錄變量和常數提供
了一個快速便捷的方法。另外，使用新的內置函數 buildRecord()，用戶還可以
在運行時指定域名和域值來動態地創建一個記錄。

在一個圖形對象上通過一個輸入端顯示多條軌迹 -- 這一功能可以讓用戶在事先
不知道將要顯示的軌迹的數目時，也能在 Agilent VEE 的圖形對象上動態地將
這些軌迹顯示出來。

面板視圖中新增了滾動條 -- 當面板視圖不足以放下所有的對象時，滾動條會自
動出現。通過改變面板對象的 "ScrollbarsEnabled" 屬性可以將這一功能打開或
關閉。缺省值是關閉。

增強的多事務操作功能 -- 本功能增強了所有基于事務的 Agilent VEE 對象 （比
如 Direct IO) 的操作。現在，用戶不僅可以使用標准的快捷鍵對多個事務同時進
行諸如複制、刪除和選擇等許多操作，還可以使用標准的快捷鍵對事務進行上移
和下移。

Home -- Agilent VEE 8.0 添加了一個新的 工具欄 按鈕 。它可以將 VEE 程序的
左上角快速地移到工作區 (Main, UserFunctions, 或 UserObjects) 的左上角。

新添加的儀器範例 -- 可以在 examples\instrumentIO\
InstrumentManagerIntergrated 處找到新添加的儀器範例。
18 Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊
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安捷倫連接轉換類产品

安捷倫提供了一整套高性能、高可靠性的产品用于連接你的計算機和儀器。
這些产品包括網絡 USB 集線器、LAN/GPIB 網關、PCI GPIB、USB/GPIB
和 USB/RS232 轉換接口。了解更多有關安捷倫連接轉換類产品的信息，請
訪問 www.agilent.com/find/io。

安捷倫的技術支持和服務

購買了 Agilent VEE Pro 或 Agilent VEE Express，您就擁有了包括启動協
助，培訓課程和升級服務在內的安捷倫全球範圍內的服務資源。 作為購買安
捷倫产品的一部分 , 您也將無需注冊就獲得免費的技術支持。

此外，您還將獲得安捷倫提供的咨詢服務。目前，分布在北美、歐洲、中東
及亞洲的 30 多家公司將協助您完成 Agilent VEE 解決方案的開發。

立即訪問 http://www.agilent.com/find/vrf 並注冊成為 Agilent VEE 電子用
戶組成員，您就可以隨時與世界各地的 Agilent VEE 專家探討有關 Agilent 
VEE 的各種問題。

E5810A E5805A 10833X 82350B 82357B
Agilent VEE Pro 8.0 和 Agilent VEE Express 8.0 快速入門手冊 19
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附錄

除了英文幫助文件外， Agilent VEE Pro 8.0 還提供其他語言的幫助文件。 
您只需將 Agilent VEE 安裝路徑下的 vee.chm 重命名為 veeEnglish.chm，
再將您所選的幫助文件命名為 vee.chm 就可以了。例如，將
veeJapanese.chm 命名為 vee.chm。
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시작하기

VEE Pro 제품군에 오신 것을 환영합니다 . Agilent VEE (Visual Engineering 
Environment) 는 개발시간을 획기적으로 단축할 수 있는 강력한 시각적인 
프로그래밍 환경을 제공합니다 . 본 안내서에서는 Agilent VEE 를 빠르고 
쉽게 배울 수 있도록 , VEE 를 설치하는 방법과 간단한 사용법을 설명합니다 . 
'USB 인터페이스를 이용한 계측기와의 통신을 설정하는 방법 ' 과 ' 파형을 
생성하고 디스플레이 하는 방법 ' 에 대한 2 개의 실습을 제공하고 있습니다 .

Agilent IO 라이브러리 설치

Agilent IO Libraries Suite 소프트웨어는 Agilent VEE Pro 또는 Agilent VEE 
Express 를 구매할 때 포함되어 있습니다 . 이 소프트웨어는 Serial, USB, 
GPIB 와 LAN 을 통한 계측기 인터페이스를 제공합니다 . 아래의 단계를 
따라 설치하십시오 .

1 Agilent IO Library Suites CD 를 PC 의 CD-ROM 드라이브에 삽입하면 
자동으로 설치가 시작되며 , 설치화면이 나타나면 Install Software 버튼
을 클릭하십시오 .
2 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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2 설치 마법사에 따라서 설치가 진행됩니다 . 디폴트 셋팅 상태로 Next 
버튼을 클릭하여 설치를 진행하십시오 .

3 Agilent Connection Expert 환영 화면이 나타납니다 . Agilent Connection 
Expert 는 PC 와 연결된 계측기를 설정합니다 . 다음 단계를 진행하기 전에 
Close Welcome Screen 버튼을 클릭하여 아래 그림의 화면을 닫을 수도 
있습니다 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 3
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Agilent VEE Pro 또는 Agilent VEE Express 설치

1 VEE Pro installation CD 를 삽입하고 Install Agilent VEE Pro Development 
또는 Install Agilent VEE Express 를 선택하십시오 . 설치마법사가 설치를 
안내 할 것입니다 .

이들 제품에 대한 차이점은 16 페이지를 참조하십시오 .

2 설치 마법사가 Microsoft .NET Framework 2.0 이 설치되어 있는지를 
체크합니다 . 설치가 되어 있지 않을 경우에는, 다음과 같은 메시지 박스가 
나타납니다 . 

Microsoft .NET Framework 2.0 의 설치가 완료되면 , 설치마법사는 1 단계에 
있는 Agilent VEE 선택화면을 통해서 설치를 안내할 것입니다 .
4 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 



VEE8_QSG.book  Page 5  Monday, March 12, 2007  3:40 PM
3 라이센스 계약 안내에 동의하고 , Next 를 클릭하십시오 .

4 Customer Information 대화상자가 나타나면 Name, Company Name과 
Product Key 를 입력하십시오 . Product Key 는 Agilent VEE Pro 또는 
Agilent VEE Express Product Key Certificate 에 있습니다 . 현 상태에서 
Next 를 클릭하십시오 . 다음 화면에서 Typical setup 을 선택하여 설치를 
완료하십시오 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 5
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Agilent VEE Pro 또는 Agilent VEE Express 실행

시작 > 모든 프로그램 > Agilent VEE Pro 8.0> VEE Pro 8.0 또는 Agilent 
VEE Express 8.0> VEE Express 8.0 의 경로를 차례로 클릭하여 Agilent 
VEE Pro 또는 Agilent VEE Express 를 실행하십시오 .

Agilent VEE Pro 또는 Agilent VEE Express Welcome 화면에서는 VEE 예
제 프로그램 , 안내서 , MATLAB 데모 (Agilent VEE Pro 에서만 제공 ) 등의 
링크가 제공됩니다 . Welcome 화면에서 제공하는 여러 기능을 검토하고 
화면을 닫으십시오 .

또한 메뉴바 (File > Open Example) 에서도 예제 프로그램을 열 수 있습니다 .

Welcome 
Screen

Program 
Explorer

Properties
Window

Tool Bar

Status Bar

Menu Bar

Workspace
6 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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계측기 통신 안내서

본 안내서에서는 , USB 인터페이스를 이용하여 계측기를 연결하는 방법을 
설명합니다 . 우선 Agilent IO Libraries Suite 14.2 가 반드시 설치되어 있어야 
합니다 . 

아래 3 단계 이후부터는 USB 계측기와 GPIB 계측기에서 사용하는 방법이 
거의 동일하므로 , 아래의 내용을 GPIB 계측기에도 적용할 수 있습니다 . 

다음의 그림들은 Agilent VEE Pro 에서 캡쳐한 화면으로 , Agilent VEE 
Express 의 화면도 이와 유사합니다 .

1 계측기를 PC 의 USB포트에 연결하고 계측기의 전원을 켜면, 새 하드웨어 
검색 마법사 화면이 나타납니다 . Windows Update 를 통한 소프트웨어 
설치화면에서 " 아니오 , 지금 연결 안함 " 을 선택하고 다음을 클릭합니다 . 
' 소프트웨어 자동으로 설치 ( 권장 )' 를 선택하고 다음을 클릭하면 설치를 
진행합니다 .

2 Assign USB device alias 대화상자가 나타나면 OK 버튼을 클릭하여 
시스템에 이 연결을 등록하십시오 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 7
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3 프로그램이 실행되어 있지 않다면 , Agilent VEE Pro 또는 Agilent VEE 
Express를 실행하십시오.툴바에 있는 Instrument Manager 버튼 퓨푸을 
클릭하십시오 .

4 Instrument Manager 화면이 나타납니다 . Find Instrument 버튼을 클릭
하면 PC 에 연결된 계측기를 자동으로 감지하고 설정합니다 . Identify 
Instrument 화면이 나타나면 Yes 를 클릭하십시오 . 이 과정에서 USB 
인터페이스에 연결된 계측기가 자동으로 인식됩니다. 아래의 예제에서는 
Agilent 34410A Digit multimeter 를 검색했습니다 .

5 대화상자의 Instrument List 에서 newInstrument를 클릭하여 하이라이트 
시키고 , Direct I/O 버튼을 클릭하여 VEE 작업영역에 newInstrument 용 
Direct I/O 오브젝트를 생성하십시오 . 이 오브젝트를 통해서 계측기에 
명령을 전송하고 계측기의 응답을 수신할 수 있습니다 .

6 Direct I/O 오브젝트에 트랜잭션을 추가하기 위하여 Direct I/O 오브젝트의 
청색 트랜잭션바를 더블클릭 합니다 .
8 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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7 I/O Transaction 대화상자에서 그림과 같이 “*IDN?” ( 인용부호 “ ”  
포함 ) 이라고 입력하고 OK 버튼을 클릭하십시오 .

*IDN?은 SCPI (Standard Commands for Programmable Instruments) 
호환 명령어로써 이 명령어를 받은 계측기는 자신의 정보를 응답하도록 
되어있습니다 .

8 계측기로 “*IDN?” 쿼리를 전송한 다음에는 계측기의 응답을 받아서 
읽어야 합니다 . 가장 하단의 트랜잭션바를 더블 클릭하여 , 새 트랜잭션
을 추가합니다 . 이번에는 그림과 같이 트랜잭션을 READ 로 , 포맷은 
STRING FORMAT 으로 변경하여 x 출력터미날로 전송하도록 선택합니다 . 
OK 버튼을 클릭하면 오브젝트에 출력터미날 x 가 자동생성됩니다 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 9
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9 메뉴바에서  Display > AlphaNumeric을 선택하여 AlphaNumeric 오브젝트를 
Direct I/O 오브젝트의 오른쪽에 배치합니다 .

10 이번에는 Direct I/O 오브젝트를 AlphaNumeric 오브젝트에 연결해야 
합니다. 마우스 커서를 Direct I/O 오브젝트의 출력터미날 가까이 가져가면 
정사각형의 박스아이콘으로 바뀝니다. 그 상태에서 마우스의 왼쪽 버튼을 
클릭하고 라인을 드래그하여 AlphaNumeric 오브젝트의 입력터미날 
근처로 이동합니다. 다시 한번 마우스의 왼쪽 버튼을 클릭하면 연결선이 
생성되고 연결이 마무리됩니다 .

11 툴바의 Run 버튼 미지을 클릭하여 프로그램을 실행합니다 .

12 AlphaNumeric 오브젝트에 계측기로부터 출력된 계측기 정보가 디스플레이 
됩니다 .

13 현재의 프로그램을 File > Save As 를 선택하여 Tutorial 1.vee 로 저장합
니다 .
10 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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Virtual Source 안내서

이번 안내서에서는 가상소스를 이용하여 파형을 생성하고 디스플레이 합니다. 
여기서 설명된 프로그램을 실행하기 위하여 계측기는 필요하지 않습니다 .

1 현재 Agilent VEE Pro 또는 Agilent VEE Express의 작업영역에서 프로그램 
중에 있다면 , 메뉴바에서 File > New 를 선택하여 새로운 VEE 프로그램을 
시작합니다 . 메뉴바에서 Device > Virtual Source > Function Generator 를 
선택하여 작업영역에 Digital Multimeter 오브젝트를 생성합니다 .

2 디폴트 상태에서는 이 Function Generator 의 Function 필드는 Cosine, 
Frequency 필드는 200Hz, Amplitude 필드는 1V 로 설정되어 있습니다 . 
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 11
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3 메뉴바에서 Display > XY Trace 를 선택하여 XY Trace 오브젝트를 
Function Generator 의 오른쪽에 배치합니다 .

4 Function Generator 의 출력터미날을 XY Trace 의 입력터미날에 연결하
십시오. 마우스 커서를 Function Generator 오브젝트 출력터미날 가까이 
가져가면 정사각형의 박스 아이콘으로 바뀝니다 . 그 상태에서 마우스의 
왼쪽 버튼을 클릭하고 라인을 드래그하여 XY Trace 오브젝트의 입력터미날 
근처로 이동합니다 . 다시 한번 마우스의 왼쪽 버튼을 클릭하면 연결선이 
생성되고 연결이 마무리됩니다 .

5 툴바에서 Run 버튼 ( ㅜ)을 클릭하면 XY Trace 오브젝트에 코사인 파형이 
생성됩니다 .
12 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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6 Display > Spectrum (Freq) > Magnitude Spectrum 을 선택하여 오브젝
트를 생성하고 작업영역에서 XY Trace 아래에 배치하십시오 .

7 4단계에서 설명한 연결선 생성 방법을 사용하여 Function Generator 의 
출력터미날에서 두 번째 라인을 생성하여 Magnitude Spectrum 오브젝트의 
입력터미날에 연결합니다 .

8 Run 버튼 (ㅜ)을 클릭하여 Magnitude Spectrum 오브젝트의 디스플레이를 
확인하십시오 . 파형이 200Hz 코사인이기 이므로 , Magnitude Spectrum 
오브젝트의 창에 200Hz 에서 피크가 생성됩니다 .

9 Function Generator 오브젝트에서 Function 필드를 Square 파형으로 
변경하십시오 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 13
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10 Run 버튼 (ㅓ)을 클릭하고 차이점을 비교하십시오. Agilent VEE는 여러 
개의 그래프를 동시에 디스플레이 할 수 있도록 유연하게 동작합니다 . 

11 지금까지 작성한 프로그램을 메뉴바에서 File > Save As 를 선택하여 
Tutorial 2.vee 로 저장하십시오 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 15
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Agilent VEE Pro 와 Agilent VEE Express 의 차이점

다음의 표는 Agilent VEE Pro 와 Agilent VEE Express 의 차이점을 설명합니다 .

항 목 Agilent VEE Pro Agilent VEE 
Express

인터페이스 GPIB, LAN, 
RS-232, VXI, PXI, 

SCXI

USB
(LiveMode 에서는 

Agilent USB계측기만 
사용 가능 )

MatlabScript 오브젝트 & MatlabScript 엔진

Agilent VEE 프로그램의 런타임 버전 생
성 및 Agilent VEE 오브젝트의 보안처리 

계측기주소를 프로그램 실행시 변경

Callable Server 기능 ( 예 , Agilent VEE 를 
ActiveX Automation server 로 호출하는 것 )

Remote Function 기능 ( 예 , 리모트 호스트 
컴퓨터에서 실행되는 다른 Agilent VEE 프로
그램을 UserFunction 으로 임포팅 하는 것 )

다른 기능들
16 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 의 새
로운 기능

추가된 실행모드 (Execution Mode) 와 데이터 종류 (Type) -- 8.0 버전에서는 , 
Agilent VEE 는 2 가지의 새로운 데이터 종류 (Int64, Boolean) 와 새로운 실행
모드 (VEE 8) 를 지원합니다 .

Watch Window 기능 -- 이 디버깅 기능은 
사용자가 프로그램을 디버깅할 때 변수의 값과 
라인/ 터미날을 보고 편집할 수 있도록 합니다 . 
프로그램은 변경된 값을 적용하여 실행됩니다 . 

Minimap 기능 -- 작업영역에서 오브젝트를 
찾는 시간을 줄일 수 있습니다 . 이 기능은 
커다란 디테일뷰 화면에서 쉽게 네비게이션 할 
수 있도록 합니다 . 또한 , 사용자가 디테일뷰의 화면 사이즈를 재조정하여 인쇄
할 수 있습니다 . Minimap 은 강력한 컨텍스트 메뉴를 제공하여 사용자가 Minimap 을 
복사 , 인쇄 , 저장 및 이메일을 발송할 수 있습니다 .

코드 자동완성 기능 및 코드의 메모 표시 기능 
-- 이 기능은 사용자가 공식을 입력할 때 키보드 
입력을 줄이고 공식에 대한 간략한 메모 및 외부의 
관련 문서를 제공합니다. 작업중인 컨텍스트 내에 
있으면서 , 필요한 정보를 찾고 , 공식 입력필드에 
단어를 입력하면 Agilent VEE 가 단어 자동완성 
기능을 이용하여 입력을 마무리합니다 .

프로그램상에서 속성변경 하기 -- Agilent VEE 오브젝트 , .NET 오브젝트와 
COM 오브젝트의 색상 , 이름 , 사이즈 , 위치 및 다른 속성들을 프로그램 상
( 실행 중에 ) 에서 변경할 수 있습니다 . 이 기능은 사용자가 Agilent VEE GUI 를 
보다 쉽고 빠르게 생성할 수 있도록 도와줄 것입니다 .
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 17
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NIDAQ 지원을 향상 시키기 위한 NIDAQmx Drivers 지원기능 강화 -- Agilent 
VEE Pro 8.0 부터는 Instruments Manager 에서 NIDAQmx 드라이버를 가진 
계측기도 자동으로 찾을 수 있습니다 .

VISA 형식의 계측기 -- I/O 디바이스를 선언하거나 사용하기 위한 동일 표준의 
접근방식 (VISA) 을 제공하기 위하여 과거 방식의 호환되지 않는 I/O 디바이스
(SICL & VISA 가 혼용된 ) 를 점차 제거하고 있습니다 . 사용자들에게 새로운 
형식의 디바이스를 사용할 것을 “권장” 하지만 , 이전 버전에 대한 호환성은 
유지됩니다 .

Record의 활용도 향상 -- Record Variables 또는 Constants 를 선언 , 생성하고 
언빌드하는 방법을 보다 빠르고 쉽게 할 수 있습니다 . 기본기능에 새로 추가된 
buildRecord() 는 프로그램을 실행할 때 필드의 이름과 필드의 값을 지정하여 
레코드를 생성할 수 있도록 합니다 .

하나의 입력핀을 통해서 그래프 오브젝트에 복수의 트레이스를 디스플레이 -- 
이 기능은 사용자가 얼마나 많은 트레이스가 필요한 지 , 인지할 필요 없이 
Agilent VEE 그래프 오브젝트에 복수의 트레이스 ( 트레이스 어레이 ) 를 디스플
레이 할 수 있도록 합니다 .

패널뷰의 스크롤 기능 추가 -- 패널뷰가 모든 오브젝트를 디스플레이 하기에 충분히 
크지 않을 때는 자동으로 스크롤바가 설정됩니다 . 이 기능은 "ScrollbarsEnabled" 
속성을 변경하여 ON/OFF 할 수 있습니다 . 디폴트 값은 OFF 입니다 . 

복수의 트랜잭션에 대한 기능 향상 -- 이 기능은 모든 Agilent VEE 트랜잭션 
기반의 오브젝트 ( 예 , Direct IO) 성능을 향상 시킵니다 . 복수의 트랜잭션에서 
여러 가지 동작 ( 복사 , 삭제 , 선택 등 ) 을 수행할 수 있고 키보드의 표준 단축
키를 이용하여 트랜잭션을 위로 또는 아래로 쉽게 이동할 수 있습니다 .

Home 툴바 버튼 -- Agilent VEE 8.0 은 프로그램의 좌측 상단을 작업영역의 
좌측 상단으로 이동시키는 새로운 툴바 버튼 을 추가하였습니다 . 
(Main, UserFunctions, 또는 UserObjects)

새로운 계측기 예제 -- 많은 계측기 샘플을 업데이트 하였으며 , examples\
instrumentIO\InstrumentManagerIntergrated 폴더에 새로운 예제를 추가하였
습니다 .
18 Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 
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Agilent Connectivity 제품

Agilent 는 PC 와 계측기를 연결하는 신뢰도가 높은 고성능 제품을 제공합니다 . 
이 제품군에는 USB 허브 , LAN/GPIB 게이트웨이 , PCI GPIB, USB/GPIB 및 
USB/RS232 인터페이스 등이 있습니다 . 웹페이지 www.agilent.com/find/io 
에서 이와 관련된 더 많은 정보를 제공합니다 .

Agilent 지원과 서비스

Agilent VEE Pro & Agilent VEE Express 와 함께 , Agilent 는 프로그램을 
시작 지원 , 교육 및 업데이트에 대해 전세계 고객에게 동일한 서비스를 
제공합니다 . Agilent VEE 제품을 구매한 사용자는 등록 절차 없이 무료로 
기술지원을 받을 수 있습니다 . 

Agilent 에서는 컨설팅 서비스도 제공합니다 . Agilent VEE 프로그램을 
개발하는데 있어 북미 , 유럽 , 중동 및 아시아의 30 여 회사에서 도움을 
제공할 수 있습니다 .

웹페이지 http://www.agilent.com/find/vrf 는 애질런트가 운영하는 VEE 
사용자 모임 (VEE electronic users group) 입니다 . 이 사이트에 등록하여 
전세계의 VEE 전문가들로부터 Agilent VEE 를 사용하는데 필요한 도움을 
받으십시오 .

E5810A E5805A 10833X 82350B 82357B
Agilent VEE Pro 8.0 & Agilent VEE Express 8.0 퀵 스타트 가이드 19

http://www.agilent.com/find/io
http://www.agilent.com/find/vrf


© Agilent Technologies, Inc. 2007

Printed in Malaysia
February 16, 2007

W1141-90025

www.agilent.com

Agilent Technologies

연락처

애질런트의 측정자동화 제품 , 어플리케
이션 서비스에 대한 자세한 내용은 아래

의 연락처로 문의하시기 바랍니다 .

미국 : 
(tel) 800 829 4444         (fax) 800 829 4433

캐나다 :
(tel) 877 894 4414         (fax) 800 746 4866

중국 :
(tel) 800 810 0189         (fax) 800 820 2816

유럽 :
(tel) 31 20 547 2111

일본 :
(tel) (81) 426 56 7832    (fax) (81) 426 56 7840

한국 :
(tel) (080) 769 0800       (fax) (080) 769 0900

남미 :
(tel) (305) 269 7500

타이완 :
(tel) 0800 047 866         (fax) 0800 286 331

다른 아시아 - 태평양 국가들 :
(tel) (65) 6375 8100        (fax) (65) 6755 0042

한국 애질런트 인터넷 홈페이지
www.agilent.com/find/assist

본 자료에 설명된 제품규격 및 설명은 
예고없이 변경될 수 있습니다 

VEE8_QSG.book  Page 17  Monday, March 12, 2007  3:40 PM

http://www.agilent.com/find/assist

	Quick Start Guide
	Kurzanleitung
	クイック・スタート・ガイド
	快速入门手册
	快速入門手冊
	퀵 스타트 가이드

